Wednesday, December 19, 2012

Holo Launcher HD Plus v1.0.8


Holo Launcher HD Plus v1.0.8
Requirements: 4.0 and up
Overview: Highly customizable Jelly Bean Launcher

Simple, powerful, fast and highly customizable home replacement, based on Android 4.1.1 Jelly Bean Launcher.